1 { config, lib, pkgs, ... }:
3 fqdn = "gitea.${config.networking.hostName}.${config.networking.domain}";
5 environment.systemPackages = [ pkgs.tea ];
9 rootUrl = if config.security.acme.acceptTerms then "https://${fqdn}" else "http://${fqdn}";
10 httpAddress = "127.0.0.1";
11 disableRegistration = true;
14 SSH_DOMAIN = "${fqdn}";
15 LANDING_PAGE = "explore";
18 DEFAULT_THEME = "arc-green";
21 APP_ID = if config.security.acme.acceptTerms then "https://${fqdn}" else "http://${fqdn}";
22 TRUSTED_FACETS = if config.security.acme.acceptTerms then "https://${fqdn}" else "http://${fqdn}";
26 helpers.webservices."${fqdn}" = {
27 port = config.services.gitea.httpPort;