3 fqdn = "git.${config.networking.fqdn}";
10 virtualHost = "${fqdn}";
12 virtualHosts."${fqdn}" = {
13 enableACME = config.security.acme.acceptTerms;
14 forceSSL = config.security.acme.acceptTerms;
19 networking.hosts."127.0.0.1" = [ "${fqdn}" ];
20 # TODO Check perms see if they are g2g. idk about recursive +x
22 systemd.tmpfiles.rules = [
23 "d '${config.services.gitweb.projectroot}' 0775 ${config.services.nginx.user} git"
24 "Z '${config.services.gitweb.projectroot}' 0775 ${config.services.nginx.user} git"
26 users.groups.git = {};