3 unstable = import <nixos-unstable> {};
21 # networking.networkmanager.enable = true;
22 # networking.networkmanager.wifi.macAddress = "random";
23 # networking.networkmanager.wifi.backend = "iwd";
24 # networking.wireless.iwd.enable = true;
26 environment.systemPackages = with pkgs; [
27 # General Purpose Tools
28 firefox # A containerized operating system designed to run closed-source and walled-garden applications.
29 fzf # fast fuzzy finder
31 chipsec # CHIPSEC is a framework for analyzing the security of PC platforms including hardware, system firmware (BIOS/UEFI), and platform components.CHIPSEC is a framework for analyzing the security of PC platforms including hardware, system firmware (BIOS/UEFI), and platform components.
32 wormhole-william # Send files between computers
33 charm # SSH-authenticated """cloud""" storage.
34 vlc # Should open pics and video. If I need a seperate picture viewer please let me know.
35 rmlint # filesystem cleanup. Finds dupes, broken symlinks, empty files/dirs, and more.
36 xplr # TUI file browser designed for integration with other CLI utilities.
37 updog # Updog is a replacement for Python's SimpleHTTPServer. It allows uploading and downloading via HTTP/S, can set ad hoc SSL certificates and use HTTP basic auth.
38 busybox # YOU KNOW IT!
41 partimage # open source disk backup software
42 etcher # burn images to sd/usb
43 fuseiso # FUSE module to mount ISO filesystem images
44 diskrsync # rsync for block devices and disk images
45 secretscanner # Tool to find secrets and passwords in container images and file systems
46 skopeo # A command line utility for various operations on container images and image repositories
47 unetbootin # A tool to create bootable live USB drives from ISO images
48 genimage # genimage is a tool to generate multiple filesystem and flash/disk images from a given root filesystem tree
51 parted # Create, destroy, resize, check, and copy partitions
52 gparted # ^ but graphical
53 gnufdisk # A command-line disk partitioning tool
54 gptfdisk # gdisk and cgdisk
55 e2fsprogs # Tools for creating and checking ext2/ext3/ext4 filesystems
56 zerofree # Zero free blocks from ext2, ext3 and ext4 file-systems
57 cryptsetup # LUKS aka encryption.
60 efitools # Tools for manipulating UEFI secure boot platforms
61 uefitool # UEFI firmware image viewer and editor
62 uefi-firmware-parser # Parse BIOS/Intel ME/UEFI firmware related structures: Volumes, FileSystems, Files, etc
63 beefi # script to create bootable EFISTUB kernel images
66 ddrescue # data recovery tool
67 ddrescueview # tool to graphically examine ddrescue mapfiles
68 testdisk # Data recovery utilities
69 testdisk-qt # ^ but graphical.
70 safecopy # Data recovery tool which tries to extract as much data as possible from a problematic (i.e. damaged sectors) source
71 sleuthkit # Open source digital forensics
72 foremost # Foremost is a console program to recover files based on their headers, footers, and internal data structures.
73 # volatility # advanced memory forensics framework, can read from crashdumps, vm dumps, hibernation files, and more. Needs py3 instead of py2. Override this and reinclude.
74 ext4magic # Recover / undelete files from ext3 or ext4 partitions
75 extundelete # Utility that can recover deleted files from an ext3 or ext4 partition
76 # photorec # file recovery utility using data carving techniques. It searches for known file headers and because there is (usually) no data fragmentation, it can recover the whole file. It can also handle some cases of low data fragmentation.
80 bedup # btrfs deduplication
81 btrbk # backup btrfs subvolumes
82 btrfs-heatmap # Visualize the layout of a mounted btrfs
83 unstable.btrfs-snap # creates and maintains history of snapshots of btrfs filesystems
84 buttersink # synchronise btrfs snapshots
85 compsize # find compression type/ratio on a file or set of files
86 dduper # Fast block-level out-of-band BTRFS deduplication tool.
89 iodine # IPv4 over DNS tunnel
90 httptunnel # bidirectional virtual data path tunnelled in HTTP requests. The requests can be sent via an HTTP proxy if so desired.
91 http2tcp # expose TCP app like ssh to the web.
92 hans # TCP over ICMP tunnel
93 clash # Powerful rule-based tunnel. wtf is a premium release?
94 chisel # A fast TCP/UDP tunnel over HTTP