]> Untitled Git - MarigoldOS/.git/blobdiff - profiles/ntopng.nix
unmodified readme, needs updating
[MarigoldOS/.git] / profiles / ntopng.nix
diff --git a/profiles/ntopng.nix b/profiles/ntopng.nix
new file mode 100644 (file)
index 0000000..97c2990
--- /dev/null
@@ -0,0 +1,15 @@
+{ config, lib, ... }:
+let
+    fqdn = "ntop.${config.networking.hostName}.${config.networking.domain}";
+in {
+  networking.hosts = {
+    "127.0.0.1" = [ fqdn ];
+  };
+  services.ntopng = {
+    enable = true;
+    services.ntopng.interfaces = [
+      "any"
+    ];
+  };
+  helpers.webservices."${fqdn}".port = config.services.ntopng.httpPort;
+}