]> Untitled Git - MarigoldOS/.git/blob - profiles/gitweb.nix
Initial Commit
[MarigoldOS/.git] / profiles / gitweb.nix
1 { config, ... }:
2 let
3   fqdn = "git.${config.networking.fqdn}";
4 in
5 {
6   services.nginx.gitweb = {
7     enable = true;
8     location = "";
9     virtualHost = "${fqdn}";
10   };
11   # BOILER
12   # PLATE
13   networking.hosts."127.0.0.1" = [ "${fqdn}" ];
14   # TODO Check perms see if they are g2g. idk about recursive +x
15   systemd.tmpfiles.rules = [
16     "d '${config.services.gitweb.projectroot}' 0775 ${config.services.nginx.user} git"
17     "Z '${config.services.gitweb.projectroot}' 0775 ${config.services.nginx.user} git"
18   ];
19   users.groups.git = {};
20 }