]> Untitled Git - MarigoldOS/.git/blob - profiles/ntopng.nix
unmodified readme, needs updating
[MarigoldOS/.git] / profiles / ntopng.nix
1 { config, lib, ... }:
2 let
3     fqdn = "ntop.${config.networking.hostName}.${config.networking.domain}";
4 in {
5   networking.hosts = {
6     "127.0.0.1" = [ fqdn ];
7   };
8   services.ntopng = {
9     enable = true;
10     services.ntopng.interfaces = [
11       "any"
12     ];
13   };
14   helpers.webservices."${fqdn}".port = config.services.ntopng.httpPort;
15 }