]> Untitled Git - MarigoldOS/.git/blob - profiles/yggdrasil.nix
Initial Commit
[MarigoldOS/.git] / profiles / yggdrasil.nix
1 {
2   services.yggdrasil = {
3     enable = true;
4     # persistentKeys = true;
5       # The NixOS module will generate new keys and a new IPv6 address each time
6       # it is started if persistentKeys is not enabled.
7
8     config = {
9       IFName = "ygg0";
10       Listen = [
11         "tls://0.0.0.0:32333"
12         "tls://[::]:32333"
13       ];
14       MulticastInterfaces = [
15         {
16           Regex = ".*";
17           Beacon = true;
18           Listen = true;
19           Port = 32332;
20           Priority = 0;
21         }
22       ];
23       Peers = [
24         # Yggdrasil will automatically connect and "peer" with other nodes it
25         # discovers via link-local multicast annoucements. Unless this is the
26         # case (it probably isn't) a node needs peers within the existing
27         # network that it can tunnel to.
28
29         # Public Peers: https://github.com/yggdrasil-network/public-peers
30       ];
31     };
32   };
33   # configFile = "/run/keys/yggdrasil.conf";
34 }