]> Untitled Git - MarigoldOS/.git/blobdiff - hosts/0x00.nix
more 0x00 stuff moved over
[MarigoldOS/.git] / hosts / 0x00.nix
diff --git a/hosts/0x00.nix b/hosts/0x00.nix
new file mode 100644 (file)
index 0000000..6fde482
--- /dev/null
@@ -0,0 +1,50 @@
+{ pkgs, lib, config, ... }:
+{
+  imports = [
+
+    # Modules
+    ../modules/nodeinfo.nix
+    ../modules/charm.nix
+    ../modules/alfis.nix
+
+    # Profiles
+    ../profiles/alias.nix
+    ../profiles/alfis.nix
+    ../profiles/charm.nix
+    ../profiles/gemini.nix
+    ../profiles/gitea.nix
+    ../profiles/hedgedoc.nix
+    ../profiles/invidious.nix
+    ../profiles/libreddit.nix
+    ../profiles/mail.nix
+    ../profiles/nitter.nix
+    ../profiles/nodeinfo.nix
+    ../profiles/oh-my-zsh.nix
+    ../profiles/plik.nix
+    ../profiles/searx.nix
+    ../profiles/twtxt.nix
+    ../profiles/warez.nix
+    ../profiles/whitebophir.nix
+    ../profiles/firewall.nix
+
+    # Requires manual config
+    ../networking/yggdrasil.nix # Contains ygg firewall rules and public peers.
+
+    # Specialty profiles (hardware). You probably won't need these.
+    ../profiles/vpsfree.nix
+  ];
+  nixpkgs.overlays = [ (import ../overlays/unstable.nix) ];
+  networking.hostName = "0x00";
+  networking.domain = "ygg";
+
+  # networking.tcpcrypt.enable = true;
+  # users.users.tcpcryptd.group = "tcpcryptd";
+  # users.groups.tcpcryptd = {};
+
+  networking.firewall.allowedTCPPorts = lib.mkForce [ 22 ];
+
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
+  system.stateVersion = "21.11";
+}