]> Untitled Git - MarigoldOS/.git/blobdiff - hosts/bootdisk.nix
more 0x00 stuff moved over
[MarigoldOS/.git] / hosts / bootdisk.nix
diff --git a/hosts/bootdisk.nix b/hosts/bootdisk.nix
new file mode 100644 (file)
index 0000000..393e277
--- /dev/null
@@ -0,0 +1,38 @@
+{ pkgs, lib, config, ... }:
+{
+  imports = [
+    # ../networking/gitns.nix
+    ../networking/yggdrasil.nix
+    ../modules/alfis.nix
+    ../profiles/oh-my-zsh.nix
+    ../profiles/alias.nix
+    ../profiles/plik.nix
+    ../profiles/warez.nix
+    ../profiles/gemini.nix
+    # ../profiles/home-manager.nix
+    ../profiles/recovery.nix
+  ];
+  networking.hostName = "nixos";
+  networking.domain = "local";
+
+  services.nginx.virtualHosts."warez.${config.networking.fqdn}" = lib.mkForce {
+    enableACME = false;
+    forceSSL = false;
+  };
+
+  services.nginx.virtualHosts."plik.${config.networking.fqdn}" = lib.mkForce {
+    enableACME = false;
+    forceSSL = false;
+  };
+
+  # networking.tcpcrypt.enable = true;
+  # users.users.tcpcryptd.group = "tcpcryptd";
+  # users.groups.tcpcryptd = {};
+
+  networking.firewall.allowedTCPPorts = [ 80 ];
+
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
+  system.stateVersion = "21.11";
+}