]> Untitled Git - MarigoldOS/.git/blob - hosts/0x00.nix
more 0x00 stuff moved over
[MarigoldOS/.git] / hosts / 0x00.nix
1 { pkgs, lib, config, ... }:
2 {
3   imports = [
4
5     # Modules
6     ../modules/nodeinfo.nix
7     ../modules/charm.nix
8     ../modules/alfis.nix
9
10     # Profiles
11     ../profiles/alias.nix
12     ../profiles/alfis.nix
13     ../profiles/charm.nix
14     ../profiles/gemini.nix
15     ../profiles/gitea.nix
16     ../profiles/hedgedoc.nix
17     ../profiles/invidious.nix
18     ../profiles/libreddit.nix
19     ../profiles/mail.nix
20     ../profiles/nitter.nix
21     ../profiles/nodeinfo.nix
22     ../profiles/oh-my-zsh.nix
23     ../profiles/plik.nix
24     ../profiles/searx.nix
25     ../profiles/twtxt.nix
26     ../profiles/warez.nix
27     ../profiles/whitebophir.nix
28     ../profiles/firewall.nix
29
30     # Requires manual config
31     ../networking/yggdrasil.nix # Contains ygg firewall rules and public peers.
32
33     # Specialty profiles (hardware). You probably won't need these.
34     ../profiles/vpsfree.nix
35   ];
36   nixpkgs.overlays = [ (import ../overlays/unstable.nix) ];
37   networking.hostName = "0x00";
38   networking.domain = "ygg";
39
40   # networking.tcpcrypt.enable = true;
41   # users.users.tcpcryptd.group = "tcpcryptd";
42   # users.groups.tcpcryptd = {};
43
44   networking.firewall.allowedTCPPorts = lib.mkForce [ 22 ];
45
46   boot.loader.systemd-boot.enable = true;
47   boot.loader.efi.canTouchEfiVariables = true;
48
49   system.stateVersion = "21.11";
50 }