]> Untitled Git - MarigoldOS/.git/blob - hosts/bootdisk.nix
more 0x00 stuff moved over
[MarigoldOS/.git] / hosts / bootdisk.nix
1 { pkgs, lib, config, ... }:
2 {
3   imports = [
4     # ../networking/gitns.nix
5     ../networking/yggdrasil.nix
6     ../modules/alfis.nix
7     ../profiles/oh-my-zsh.nix
8     ../profiles/alias.nix
9     ../profiles/plik.nix
10     ../profiles/warez.nix
11     ../profiles/gemini.nix
12     # ../profiles/home-manager.nix
13     ../profiles/recovery.nix
14   ];
15   networking.hostName = "nixos";
16   networking.domain = "local";
17
18   services.nginx.virtualHosts."warez.${config.networking.fqdn}" = lib.mkForce {
19     enableACME = false;
20     forceSSL = false;
21   };
22
23   services.nginx.virtualHosts."plik.${config.networking.fqdn}" = lib.mkForce {
24     enableACME = false;
25     forceSSL = false;
26   };
27
28   # networking.tcpcrypt.enable = true;
29   # users.users.tcpcryptd.group = "tcpcryptd";
30   # users.groups.tcpcryptd = {};
31
32   networking.firewall.allowedTCPPorts = [ 80 ];
33
34   boot.loader.systemd-boot.enable = true;
35   boot.loader.efi.canTouchEfiVariables = true;
36
37   system.stateVersion = "21.11";
38 }