]> Untitled Git - MarigoldOS/.git/blob - profiles/alias.nix
more 0x00 stuff moved over
[MarigoldOS/.git] / profiles / alias.nix
1 { pkgs, lib, ... }:
2 {
3   environment.shellAliases = {
4   # Aliases - For when you want to save keystrokes
5
6   ## Better defaults
7   cp = "cp -i";    # Confirm before overwriting something
8   ln = "ln -i";    # Confirm before overwriting something
9   mv = "mv -i";    # Confirm before overwriting something
10   df = "df -h";    # Human-readable sizes
11   free = "free -m";    # Show sizes in MB
12   ls = "ls -h --color=auto";    # Human readable, Color
13   sudo = lib.mkDefault "sudo ";    # ending in space allows next word to be aliased.
14   diff = "diff --color=auto";
15   grep = "grep --color=auto";
16   ip = "ip --color=auto";
17   dir = "dir --color=auto";
18
19   md = "mkdir";
20   # shit = "sudo !!";
21
22   lswifi = "nmcli device wifi list --rescan yes";
23
24   pip3s = "pip3 search";
25   pip3i = "pip3 install";
26   pms = "nix search"; # Package manager search.  Was originally pacman search, but works equally we  ll for this  .
27   pmi = "  nix-env -iA"; # Package manager install. Installs imperitively to user
28   pmiu   = "nix-env -f channel:nixos-unstable -iA"; # Same as above but unstable channel
29   pmis = "nix-env -i"; # the s stands for... slow, sketchy, something
30
31   sshfs = "sshfs -o auto_unmount -o reconnect";
32   sshfsc = "sshfs -o auto_unmount -o reconnect -o auto_cache";
33
34   ## Shortcuts to Common Args
35   ### NixOS stuff
36   rebuild = "sudo nixos-rebuild test";
37   rebuild-lock = "sudo nixos-rebuild switch";
38   nsp = "nix-shell -p";
39   # nix-index-update = "${pkgs.nix-index}/bin/nix-index";
40   nt = "nix-top";
41
42   ## Full File search
43   ffs = "grep --line-buffered --color=never -r '' * | ${pkgs.fzf}/bin/fzf";
44
45   ### ls
46   la = "ls -Ah --color=auto";    # Show hidden files
47   ll = "ls -lh --color=auto";    # Show file size, modified date
48   lla = "ls -lAh --color=auto";    # Show everything
49
50   ## Lighternet
51   # gopher = "${pkgs.ncgopher}/bin/ncgopher";
52   # gemini = "${pkgs.amfora}/bin/amfora";
53
54   ### Taskwarrior
55   # twa = "${pkgs.taskwarrior}/bin/task add";
56   # twm = "${pkgs.taskwarrior}/bin/task modify";
57
58   ### IPFS
59   #ipfs = "sudo -u ipfs ipfs";
60
61   nixed = "nano /etc/nixos/configuration.nix";
62   cdnix = "cd /etc/nixos/";
63
64   aliased = "nano $HOME/.alias && source $HOME/.alias"; # Same but alias and functions
65   zshed = "nano $HOME/.zshrc && source $HOME/.zshrc"; # Edit zshrc then source it
66
67   ## Moving Around
68   "cd.." = "cd ..";
69   "cd..." = "cd ../..";
70   "cd...."= "cd ../../..";
71   "cd....." = "cd ../../../..";
72   "cd......" = "cd ../../../../..";
73
74   lsgrep = "ls -a | grep -i";
75   hgrep = "history | grep -i";
76   psgrep = "ps aux | grep -i";
77
78   wget = "${pkgs.wget}/bin/wget -c";
79   chown = "chown --preserve-root";
80   chmod = "chmod --preserve-root";
81   chgrp = "chgrp --preserve-root";
82
83   # app shortcuts
84   # what = "${pkgs.goldendict}/bin/goldendict";# Instant lookup in dictionary or wikipedia
85   ydl = "${pkgs.yt-dlp}/bin/yt-dlp";
86   # ydlp = "${pkgs.yt-dlp}/bin/yt-dlp --proxy socks5://127.0.0.1:9090";
87   # ydlp2 = "${pkgs.yt-dlp}/bin/yt-dlp --proxy socks5://127.0.0.1:9091";
88   ydlm = "${pkgs.yt-dlp}/bin/yt-dlp -o '%(artist)s-%(title)s.%(ext)s' --add-metadata -x --audio-quality 0";
89   ydlmp = "${pkgs.yt-dlp}/bin/yt-dlp -o '%(artist)s-%(album)s/%(playlist_index)s-%(artist)s-%(title)s.%(ext)s' --add-metadata -x --audio-quality 0";
90   youtube-dl = "${pkgs.yt-dlp}/bin/yt-dlp";
91
92   };
93 }